#119 – UpgRAID

Nanu?! Gleich ein Rechtschreibfehler in der ersten Zeile (Überschrift) des Blogartikels? Hat die Revision da geschlafen oder was?!

Ich kann euch beruhigen, der Fehler ist ganz allein auf meinen Mist gewachsen. Tatsächlich war das kleine Wortspiel Absicht, denn heute wollen wir versuchen das alte RAID-System aus Artikel 103 etwas upzugraden! 🙂

Wer sich erinnert – gegen Ende des Artikels habe ich erwähnt, dass ich beim Unternehmen, welches das RAID-System vor über 20 Jahren verkauft hat, eine Anfrage bzgl. maximaler Ausbaustufe des RAID-Systems gestellt und selbst nach so vielen Jahren eine kompetente Antwort erhalten habe. Daumen hoch dafür! 🙂

Der Support meinte, das System unterstütze Plattenkapazitäten bis zu 137 GB, allerdings schränkten sie ein, dass es möglicherweise bei dieser Größe nicht gelingen könnte über alle sechs Platten ein RAID-Set anzulegen, da die maximale RAID-Set-Kapazität bei 300 GB läge und somit zur Sicherheit sechs 60 GB HDD verwendet werden sollten…

Blöd nur, dass 60 GB-Platten eine eher „ungewöhnliche“ Größe sind/waren. Ich habe echt lange gesucht, bin aber leider nicht fündig geworden. Dafür konnte ich sechs baugleiche 80 GB Platten (Modell DiamondPlus 9, 7200 U/min) auftreiben! 🙂

Fun Fact: Zumindest bin ich der Marke treu geblieben – die original verbauten Platten (Modell 91303D6, 5400 U/min, 13 GB) sind auch von Maxtor. Mit Baujahren zwischen 2003 und 2004 sind die „neuen“ Platten auch gerade mal knapp vier Jahre neuer als die bisherigen! 😀

Frei nach den Mottos „auf Gut glück“ und „wird schon schief gehen“ wollen wir es mal mit diesen Platten probieren. Immerhin steht ja im Handbuch etwas von 120 GB, aber ob mit „Maximum Fault Tolerant Capacity“ auch gleichzeitig die maximale Kapazität gemeint ist weiß ich nicht…

Fun Fact: Selbst diese sechs baugleichen Platten zu finden war nicht einfach. So alte IDE-Platten wachsen leider nicht auf Bäumen und für so ein „just for fun“-Projekt möchte man natürlich auch möglichst wenig Geld hinblättern…

No risk – no fun! Wie könnte ich bei so einer Challenge widerstehen? 🙂 Also – nichts wie los: Mit selbstgebasteltem Schlüssel werden die Platten schnell entfernt…

…abgeschraubt…

…abgesteckt…

…und gegen „neue“, bzw. größere Platten getauscht:

Das macht man dann insgesamt sechs Mal, schaut auf die Uhr und stellt mit Erschrecken fest, dass schon wieder eine halbe Stunde rum ist! 😀

Jetzt kommt der spannende Augenblick – es wird Zeit das Monstrum einzuschalten… Zumindest leuchtet noch etwas… 😀

Doch leider fliegt uns prompt eine „Configuration Error“-Fehlermeldung entgegen. Na, das hätte mich aber auch gewundert, wenn es auf Anhieb geklappt hätte! 😀 Ich gehe mal schwer davon aus, dass ich das RAID-System neu initialisieren muss, damit es die neuen/größeren Platten frisst. Der Prozess lässt sich über die Enter-Taste auslösen. Dabei müssen einige – aus heutiger Sicht teils merkwürdige – Parameter gesetzt werden. Keine Angst, ich erspare euch die Details… 😉

Fun Fact: Wie bei jedem guten Gerät ist das Admin-Passwort natürlich „0000“! 😀

Doch auch leider dieser Schritt führte nicht zum Erfolg. Immerhin bekommen wir jetzt einen anderen Fehler nach dem Neustart:

Die einzelnen Platten leuchten auch noch „rot“ auf. Hm, vielleicht liegt es daran, dass die Platten zu groß sind und das RAID nichts mit ihnen anfangen kann? Ich habe die Konfiguration erneut mit RAID-Level 1 durchgeführt (um das vom Support beschriebene Limit nicht zu überschreiten) – leider bleibt der „No Configuration“-Fehler erhalten und die LEDs leuchten weiterhin rot.

Ok, neuer Ansatz. Vielleicht werden die Platten nicht erkannt, weil sie nicht richtig gejumpert sind? Mal nachsehen…

Tatsächlich haben die alten Platten eine äußerst merkwürdige (meiner Meinung nach ungültige) Jumper-Konfiguration – keine Ahnung wieso das so gemacht wurde. Ich denke ich versuche erst mal die einzelnen Platten von CS (Cable Select) auf Master zu jumpern…

Und siehe da – diesmal scheint sich etwas zu tun! Nach einer erneuten Neuinitialisierung werden die Platten erkannt und es läuft der Formatierungsvorgang…

Hm, ca. 5 Minuten später stehen wir erst bei 1,5%. Wie lange das wohl dauert?

Schlappe fünfeinhalb Stunden später (kein Witz! :D) scheint das System sich vollständig initialisiert zu haben. Zumindest werden keine Fehlermeldungen mehr angezeigt und es sieht so aus als würden alle Platten einwandfrei erkannt werden! 🙂

Jetzt bleibt eigentlich nur noch zu prüfen, ob sich der Speicherplatz unter Windows auch nutzen lässt. Also schnell den guten alten Shuttle mit Windows 2000 anschmeißen und über den verbauten SCSI-Controller zugreifen…

Hm, trotzdem sehen wir das Laufwerk leider noch nicht im Arbeitsplatz:

Das ist eigentlich auch gar kein Wunder, denn wir haben das Teil ja auch noch gar nicht als Datenträger konfiguriert! Also nichts wie ab in die Datenträgerverwaltung:

Windows 2000 hat die Eigenheit, dass es größere Laufwerke als dynamische Datenträger (und nicht als Basisfestplatten) formatieren möchte. Dem Wunsch muss man (gedrängt von einem sehr merkwürdigen Assistenten) leider nachkommen, da sonst die Festplatte überhaupt nicht initialisiert wird.

Fun Fact: Alles kein Problem, denn anschließend lässt sich die Platte mit einem Klick in einen Basisdatenträger zurückkonvertieren! 🙂

Ist das geschafft muss auf dem frischen Laufwerk eigentlich nur noch eine Partition (NTFS) angelegt und formatiert werden:

Wenige Minuten später ist das System einsatzbereit und auch im Arbeitsplatz sichtbar. Wow – 372 GB. Ich weiß ja gar nicht was ich mit so viel Platz anfangen soll? 😉

Was wäre geeigneter für eine erste Sicherung als die retrololo-Blogartikel? 😉

Fun Fact: Der Ordner hat mittlerweile auch schon knappe 50 GB und ca. 54.000 Dateien. Und das, obwohl ich die richtig „dicken Brummer“ (z.B. so Sachen wie PS2-Images aus Artikel 61) schon an andere Speicherorte verlegt habe. Echt irre, was sich da so alles an Bildern und Text ansammelt! 🙂

Ich war überrascht, dass der Kopiervorgang von einem USB-3.1-Stick auf das RAID-System „nur“ ca. 1,5 Stunden gedauert hat. Das Kopieren der Dateien auf den Stick via USB 3.0-Port hat auch schon ca. 50 Minuten gedauert (zugegeben, es ist kein besonders toller Stick mit einer ziemlich niedrigen Schreibrate).

Fun Fact: Ich denke mir kommt zugute, dass auf dem Shuttle bereits SP4 für Windows 2000 installiert ist, welches die Unterstützung für USB2.0 einführte! Mit USB1.0 oder 1.1 sähe das vermutlich ganz anders aus! 🙂

Zum Abgleich von Dateien unterschiedlicher Quellen (Laufwerke oder Verzeichnisse) verwende ich immer ein Open Source Tool namens „FreeFileSync“. Eins kann ich euch sagen – es war gar nicht so einfach noch eine alte Version zu finden, die mit Windows 2000 kompatibel ist! 😀

Als letztes sollten wir auch nochmal ein Ausfallszenario testen – nur um sicher zu gehen, dass alles noch funktioniert. Gut, dass ich ein paar Wochen später tatsächlich noch eine weitere DiamondPlus 9 IDE-Platte auf eBay gefunden habe! 🙂

Fun Fact: Diesmal hatte ich wirklich Glück! Das gute Stück habe ich für schlappe 2,30€ ersteigert. Da war der (versicherte) Versand mit knapp 5€ bei weitem teurer! 😀

Diese habe ich in den Wechselrahmen für die Austauschplatte montiert, im laufenden Betrieb eine Platte entfernt und die neue eingesetzt:

Weitere fünf Stunden später ist der Rebuild-Prozess beendet und siehe da – alle Daten sind noch da! Ich denke jetzt kann ich beruhigt Feierabend machen. Zumindest ist mein Retro-Blog jetzt – passenderweise mit Retro-Technologie – gesichert 😉

In diesem Sinne, bis die Tage! 🙂

Ein Kommentar zu „#119 – UpgRAID

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s